Power Automate Exchange

Please login or click SIGN UP FOR FREE to create your FlowUG account to join this user group.

Resource not found for the segment issue in Power Automate/Microsoft Flow

By Nagaraja Emmadisetty posted May 04, 2020 06:34 AM

  


Recently , I have come across this issue with Power Automate while I am trying to create a record using “Create a new record ” action with Common Data Service(Current environment) connector based on some trigger.

I am not doing any complex stuff, just creating a quote line record and referencing a quote record. Referencing records is as simple as using dynamic content and populating it to a lookup attribute right !!! No, its not. Let’s see.



I just run the flow with the above setup and flow run got failed with “Resource not found for the segment ‘c262238e-fc89-ea12-ba11-000d3ab615df'”



After some digging , found the cause. The new CDS ( Current environment) is the culprit. Issue is with the way of referencing attributes .It expects referenced attribute values in “Odata Id” format i.e

EntityNameInPlural(Record’sId/GUID).

So here in my case, for quote lookup attribute I should give like /quotes/(Record’s Id/GUID).

After making the above change, flow has run successfully.

The interesting thing is If you use old CDS connector, you wont face this issue. But we cannot be compromised to use old one cause the new connector gives us lot of advantages. Like, option to configure multiple trigger . Read here.

If you want to know the difference between CDS vs CDS (Current environment) connectors, refer this excellent article by Sara Lagerquist (MVP)

Hope it helps. Follow my blog here.



0 comments
9 views

Permalink